layerscape: add layerscape's SATA driver package
[openwrt/openwrt.git] / target / linux / layerscape / image / armv8_64b.mk
index b190e0c041d64e21518202a7a22a1cd1e4500e8f..6ed3e7c15570046b2389027697e0a8cd966bc4b7 100644 (file)
@@ -12,20 +12,21 @@ define Device/Default
   KERNEL := kernel-bin | gzip | uImage gzip
   KERNEL_LOADADDR := 0x80080000
   KERNEL_ENTRY_POINT := 0x80080000
+  DEVICE_DTS = freescale/$(subst _,-,$(1))
+  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
   IMAGE_SIZE := 64m
   IMAGE/sysupgrade.bin := append-kernel | pad-to 16M | \
     append-rootfs | pad-rootfs | \
     check-size $(LS_SYSUPGRADE_IMAGE_SIZE) | append-metadata
 endef
 
-define Device/ls1012afrdm
+define Device/fsl_ls1012a-frdm
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := FRDM-LS1012A
   DEVICE_PACKAGES += \
     layerscape-ppfe \
-    tfa-ls1012afrdm \
+    tfa-ls1012a-frdm \
     kmod-ppfe
-  DEVICE_DTS := freescale/fsl-ls1012a-frdm
   BLOCKSIZE := 256KiB
   IMAGE/firmware.bin := \
     ls-clean | \
@@ -41,18 +42,16 @@ define Device/ls1012afrdm
     check-size $(LS_SYSUPGRADE_IMAGE_SIZE) | append-metadata
   KERNEL := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
   KERNEL_INITRAMFS := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
-  SUPPORTED_DEVICES := fsl,ls1012a-frdm
 endef
-TARGET_DEVICES += ls1012afrdm
+TARGET_DEVICES += fsl_ls1012a-frdm
 
-define Device/ls1012ardb
+define Device/fsl_ls1012a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1012A-RDB
   DEVICE_PACKAGES += \
     layerscape-ppfe \
-    tfa-ls1012ardb \
+    tfa-ls1012a-rdb \
     kmod-ppfe
-  DEVICE_DTS := freescale/fsl-ls1012a-rdb
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -62,16 +61,15 @@ define Device/ls1012ardb
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
     append-rootfs | pad-rootfs | check-size
-  SUPPORTED_DEVICES := fsl,ls1012a-rdb
 endef
-TARGET_DEVICES += ls1012ardb
+TARGET_DEVICES += fsl_ls1012a-rdb
 
-define Device/ls1012afrwy
+define Device/fsl_ls1012a-frwy-sdboot
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := FRWY-LS1012A
   DEVICE_PACKAGES += \
     layerscape-ppfe \
-    tfa-ls1012afrwy \
+    tfa-ls1012a-frwy-sdboot \
     kmod-ppfe
   DEVICE_DTS := freescale/fsl-ls1012a-frwy
   FILESYSTEMS := ext4
@@ -94,18 +92,20 @@ define Device/ls1012afrwy
     ls-append-sdhead $(1) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
-  SUPPORTED_DEVICES := fsl,ls1012a-frwy-sdboot
 endef
-TARGET_DEVICES += ls1012afrwy
+TARGET_DEVICES += fsl_ls1012a-frwy-sdboot
 
-define Device/ls1043ardb
+define Device/fsl_ls1043a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1043A-RDB
   DEVICE_VARIANT := Default
   DEVICE_PACKAGES += \
     layerscape-fman \
-    tfa-ls1043ardb \
-    fmc fmc-eth-config
+    tfa-ls1043a-rdb \
+    fmc fmc-eth-config \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
   IMAGE/firmware.bin := \
     ls-clean | \
@@ -116,18 +116,20 @@ define Device/ls1043ardb
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
     append-rootfs | pad-rootfs | check-size
-  SUPPORTED_DEVICES := fsl,ls1043a-rdb
 endef
-TARGET_DEVICES += ls1043ardb
+TARGET_DEVICES += fsl_ls1043a-rdb
 
-define Device/ls1043ardb-sdboot
+define Device/fsl_ls1043a-rdb-sdboot
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1043A-RDB
   DEVICE_VARIANT := SD Card Boot
   DEVICE_PACKAGES += \
     layerscape-fman \
-    tfa-ls1043ardb-sdboot \
-    fmc fmc-eth-config
+    tfa-ls1043a-rdb-sdboot \
+    fmc fmc-eth-config \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
   FILESYSTEMS := ext4
   IMAGES := sdcard.img sysupgrade.bin
@@ -137,7 +139,7 @@ define Device/ls1043ardb-sdboot
     ls-append $(1)-bl2.pbl | pad-to 1M | \
     ls-append $(1)-fip.bin | pad-to 5M | \
     ls-append $(1)-uboot-env.bin | pad-to 9M | \
-    ls-append ls1043ardb-fman.bin | pad-to 15M | \
+    ls-append fsl_ls1043a-rdb-fman.bin | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
@@ -146,18 +148,20 @@ define Device/ls1043ardb-sdboot
     ls-append-sdhead $(1) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
-  SUPPORTED_DEVICES := fsl,ls1043a-rdb-sdboot
 endef
-TARGET_DEVICES += ls1043ardb-sdboot
+TARGET_DEVICES += fsl_ls1043a-rdb-sdboot
 
-define Device/ls1046ardb
+define Device/fsl_ls1046a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1046A-RDB
   DEVICE_VARIANT := Default
   DEVICE_PACKAGES += \
     layerscape-fman \
-    tfa-ls1046ardb \
-    fmc fmc-eth-config
+    tfa-ls1046a-rdb \
+    fmc fmc-eth-config \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
   IMAGE/firmware.bin := \
     ls-clean | \
@@ -168,18 +172,20 @@ define Device/ls1046ardb
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
     append-rootfs | pad-rootfs | check-size
-  SUPPORTED_DEVICES := fsl,ls1046a-rdb
 endef
-TARGET_DEVICES += ls1046ardb
+TARGET_DEVICES += fsl_ls1046a-rdb
 
-define Device/ls1046ardb-sdboot
+define Device/fsl_ls1046a-rdb-sdboot
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1046A-RDB
   DEVICE_VARIANT := SD Card Boot
   DEVICE_PACKAGES += \
     layerscape-fman \
-    tfa-ls1046ardb-sdboot \
-    fmc fmc-eth-config
+    tfa-ls1046a-rdb-sdboot \
+    fmc fmc-eth-config \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
   FILESYSTEMS := ext4
   IMAGES := sdcard.img sysupgrade.bin
@@ -189,7 +195,7 @@ define Device/ls1046ardb-sdboot
     ls-append $(1)-bl2.pbl | pad-to 1M | \
     ls-append $(1)-fip.bin | pad-to 5M | \
     ls-append $(1)-uboot-env.bin | pad-to 9M | \
-    ls-append ls1046ardb-fman.bin | pad-to 15M | \
+    ls-append fsl_ls1046a-rdb-fman.bin | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
@@ -198,20 +204,21 @@ define Device/ls1046ardb-sdboot
     ls-append-sdhead $(1) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
-  SUPPORTED_DEVICES := fsl,ls1046a-rdb-sdboot
 endef
-TARGET_DEVICES += ls1046ardb-sdboot
+TARGET_DEVICES += fsl_ls1046a-rdb-sdboot
 
-define Device/ls1088ardb
+define Device/fsl_ls1088a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1088A-RDB
   DEVICE_VARIANT := Default
   DEVICE_PACKAGES += \
     layerscape-mc \
     layerscape-dpl \
-    tfa-ls1088ardb \
-    restool
-  DEVICE_DTS := freescale/fsl-ls1088a-rdb
+    tfa-ls1088a-rdb \
+    restool \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -223,19 +230,21 @@ define Device/ls1088ardb
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
     append-rootfs | pad-rootfs | check-size
-  SUPPORTED_DEVICES := fsl,ls1088a-rdb
 endef
-TARGET_DEVICES += ls1088ardb
+TARGET_DEVICES += fsl_ls1088a-rdb
 
-define Device/ls1088ardb-sdboot
+define Device/fsl_ls1088a-rdb-sdboot
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1088A-RDB
   DEVICE_VARIANT := SD Card Boot
   DEVICE_PACKAGES += \
     layerscape-mc \
     layerscape-dpl \
-    tfa-ls1088ardb-sdboot \
-    restool
+    tfa-ls1088a-rdb-sdboot \
+    restool \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1088a-rdb
   FILESYSTEMS := ext4
   IMAGES := sdcard.img sysupgrade.bin
@@ -245,9 +254,9 @@ define Device/ls1088ardb-sdboot
     ls-append $(1)-bl2.pbl | pad-to 1M | \
     ls-append $(1)-fip.bin | pad-to 5M | \
     ls-append $(1)-uboot-env.bin | pad-to 10M | \
-    ls-append ls1088ardb-mc.itb | pad-to 13M | \
-    ls-append ls1088ardb-dpl.dtb | pad-to 14M | \
-    ls-append ls1088ardb-dpc.dtb | pad-to 15M | \
+    ls-append fsl_ls1088a-rdb-mc.itb | pad-to 13M | \
+    ls-append fsl_ls1088a-rdb-dpl.dtb | pad-to 14M | \
+    ls-append fsl_ls1088a-rdb-dpc.dtb | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
@@ -256,19 +265,18 @@ define Device/ls1088ardb-sdboot
     ls-append-sdhead $(1) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
-  SUPPORTED_DEVICES := fsl,ls1088a-rdb-sdboot
 endef
-TARGET_DEVICES += ls1088ardb-sdboot
+TARGET_DEVICES += fsl_ls1088a-rdb-sdboot
 
-define Device/ls2088ardb
+define Device/fsl_ls2088a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS2088ARDB
   DEVICE_PACKAGES += \
     layerscape-mc \
     layerscape-dpl \
-    tfa-ls2088ardb \
-    restool
-  DEVICE_DTS := freescale/fsl-ls2088a-rdb
+    tfa-ls2088a-rdb \
+    restool \
+    kmod-ahci-qoriq
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -280,11 +288,10 @@ define Device/ls2088ardb
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
     append-rootfs | pad-rootfs | check-size
-  SUPPORTED_DEVICES := fsl,ls2088a-rdb
 endef
-TARGET_DEVICES += ls2088ardb
+TARGET_DEVICES += fsl_ls2088a-rdb
 
-define Device/traverse-ls1043
+define Device/traverse_ls1043
   DEVICE_VENDOR := Traverse
   DEVICE_MODEL := LS1043 Boards
   KERNEL_NAME := Image
@@ -314,4 +321,4 @@ define Device/traverse-ls1043
   MKUBIFS_OPTS := -m 2048 -e 124KiB -c 4096
   SUPPORTED_DEVICES := traverse,ls1043s traverse,ls1043v
 endef
-TARGET_DEVICES += traverse-ls1043
+TARGET_DEVICES += traverse_ls1043