layerscape: add layerscape's SATA driver package
[openwrt/openwrt.git] / target / linux / layerscape / image / armv8_64b.mk
index c2e091fb2af17e54cddfaad5231ad28bcaced5db..6ed3e7c15570046b2389027697e0a8cd966bc4b7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright 2018 NXP
+# Copyright 2018-2020 NXP
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,25 +7,27 @@
 
 define Device/Default
   PROFILES := Default
-  IMAGES := firmware.bin
-  FILESYSTEMS := ubifs
-  MKUBIFS_OPTS := -m 1 -e 262016 -c 128
+  IMAGES := firmware.bin sysupgrade.bin
+  FILESYSTEMS := squashfs
   KERNEL := kernel-bin | gzip | uImage gzip
   KERNEL_LOADADDR := 0x80080000
   KERNEL_ENTRY_POINT := 0x80080000
+  DEVICE_DTS = freescale/$(subst _,-,$(1))
+  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
+  IMAGE_SIZE := 64m
+  IMAGE/sysupgrade.bin := append-kernel | pad-to 16M | \
+    append-rootfs | pad-rootfs | \
+    check-size $(LS_SYSUPGRADE_IMAGE_SIZE) | append-metadata
 endef
 
-define Device/ls1012afrdm
+define Device/fsl_ls1012a-frdm
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := FRDM-LS1012A
   DEVICE_PACKAGES += \
     layerscape-ppfe \
-    tfa-ls1012afrdm \
+    tfa-ls1012a-frdm \
     kmod-ppfe
-  DEVICE_DTS := freescale/fsl-ls1012a-frdm
-  UBINIZE_OPTS := -E 5
   BLOCKSIZE := 256KiB
-  PAGESIZE := 1
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -33,23 +35,23 @@ define Device/ls1012afrdm
     ls-append $(1)-uboot-env.bin | pad-to 10M | \
     ls-append pfe.itb | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
-    append-kernel | pad-to 32M | \
-    append-ubi | check-size 67108865
+    append-kernel | pad-to $$(BLOCKSIZE) | \
+    append-rootfs | pad-rootfs | check-size
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$(BLOCKSIZE) | \
+    append-rootfs | pad-rootfs | \
+    check-size $(LS_SYSUPGRADE_IMAGE_SIZE) | append-metadata
+  KERNEL := kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
   KERNEL_INITRAMFS := kernel-bin | fit none $$(DTS_DIR)/$$(DEVICE_DTS).dtb
 endef
-TARGET_DEVICES += ls1012afrdm
+TARGET_DEVICES += fsl_ls1012a-frdm
 
-define Device/ls1012ardb
+define Device/fsl_ls1012a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1012A-RDB
   DEVICE_PACKAGES += \
     layerscape-ppfe \
-    tfa-ls1012ardb \
+    tfa-ls1012a-rdb \
     kmod-ppfe
-  DEVICE_DTS := freescale/fsl-ls1012a-rdb
-  UBINIZE_OPTS := -E 5
-  BLOCKSIZE := 256KiB
-  PAGESIZE := 1
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -58,20 +60,20 @@ define Device/ls1012ardb
     ls-append pfe.itb | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
-    append-ubi | check-size 67108865
+    append-rootfs | pad-rootfs | check-size
 endef
-TARGET_DEVICES += ls1012ardb
+TARGET_DEVICES += fsl_ls1012a-rdb
 
-define Device/ls1012afrwy
+define Device/fsl_ls1012a-frwy-sdboot
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := FRWY-LS1012A
   DEVICE_PACKAGES += \
     layerscape-ppfe \
-    tfa-ls1012afrwy \
+    tfa-ls1012a-frwy-sdboot \
     kmod-ppfe
   DEVICE_DTS := freescale/fsl-ls1012a-frwy
   FILESYSTEMS := ext4
-  IMAGES := firmware.bin sdcard.img
+  IMAGES := firmware.bin sdcard.img sysupgrade.bin
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 128K | \
@@ -85,19 +87,26 @@ define Device/ls1012afrwy
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
+  IMAGE/sysupgrade.bin := \
+    ls-clean | \
+    ls-append-sdhead $(1) | pad-to 16M | \
+    append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+    append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
 endef
-TARGET_DEVICES += ls1012afrwy
+TARGET_DEVICES += fsl_ls1012a-frwy-sdboot
 
-define Device/ls1043ardb
+define Device/fsl_ls1043a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1043A-RDB
   DEVICE_VARIANT := Default
   DEVICE_PACKAGES += \
-    layerscape-fman-ls1043ardb \
-    tfa-ls1043ardb \
-    fmc fmc-eth-config
+    layerscape-fman \
+    tfa-ls1043a-rdb \
+    fmc fmc-eth-config \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
-  FILESYSTEMS := squashfs
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -106,46 +115,54 @@ define Device/ls1043ardb
     ls-append $(1)-fman.bin | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
-    append-rootfs | pad-rootfs | check-size 67108865
+    append-rootfs | pad-rootfs | check-size
 endef
-TARGET_DEVICES += ls1043ardb
+TARGET_DEVICES += fsl_ls1043a-rdb
 
-define Device/ls1043ardb-sdboot
+define Device/fsl_ls1043a-rdb-sdboot
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1043A-RDB
   DEVICE_VARIANT := SD Card Boot
   DEVICE_PACKAGES += \
-    layerscape-fman-ls1043ardb \
-    tfa-ls1043ardb-sdboot \
-    fmc fmc-eth-config
+    layerscape-fman \
+    tfa-ls1043a-rdb-sdboot \
+    fmc fmc-eth-config \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1043a-rdb-sdk
   FILESYSTEMS := ext4
-  IMAGES := sdcard.img
+  IMAGES := sdcard.img sysupgrade.bin
   IMAGE/sdcard.img := \
     ls-clean | \
     ls-append-sdhead $(1) | pad-to 4K | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
     ls-append $(1)-fip.bin | pad-to 5M | \
     ls-append $(1)-uboot-env.bin | pad-to 9M | \
-    ls-append ls1043ardb-fman.bin | pad-to 15M | \
+    ls-append fsl_ls1043a-rdb-fman.bin | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
+  IMAGE/sysupgrade.bin := \
+    ls-clean | \
+    ls-append-sdhead $(1) | pad-to 16M | \
+    append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+    append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
 endef
-TARGET_DEVICES += ls1043ardb-sdboot
+TARGET_DEVICES += fsl_ls1043a-rdb-sdboot
 
-define Device/ls1046ardb
+define Device/fsl_ls1046a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1046A-RDB
   DEVICE_VARIANT := Default
   DEVICE_PACKAGES += \
-    layerscape-fman-ls1046ardb \
-    tfa-ls1046ardb \
-    fmc fmc-eth-config
+    layerscape-fman \
+    tfa-ls1046a-rdb \
+    fmc fmc-eth-config \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
-  UBINIZE_OPTS := -E 5
-  BLOCKSIZE := 256KiB
-  PAGESIZE := 1
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -154,47 +171,54 @@ define Device/ls1046ardb
     ls-append $(1)-fman.bin | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
-    append-ubi | check-size 67108865
+    append-rootfs | pad-rootfs | check-size
 endef
-TARGET_DEVICES += ls1046ardb
+TARGET_DEVICES += fsl_ls1046a-rdb
 
-define Device/ls1046ardb-sdboot
+define Device/fsl_ls1046a-rdb-sdboot
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1046A-RDB
   DEVICE_VARIANT := SD Card Boot
   DEVICE_PACKAGES += \
-    layerscape-fman-ls1046ardb \
-    tfa-ls1046ardb-sdboot \
-    fmc fmc-eth-config
+    layerscape-fman \
+    tfa-ls1046a-rdb-sdboot \
+    fmc fmc-eth-config \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1046a-rdb-sdk
   FILESYSTEMS := ext4
-  IMAGES := sdcard.img
+  IMAGES := sdcard.img sysupgrade.bin
   IMAGE/sdcard.img := \
     ls-clean | \
     ls-append-sdhead $(1) | pad-to 4K | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
     ls-append $(1)-fip.bin | pad-to 5M | \
     ls-append $(1)-uboot-env.bin | pad-to 9M | \
-    ls-append ls1046ardb-fman.bin | pad-to 15M | \
+    ls-append fsl_ls1046a-rdb-fman.bin | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
+  IMAGE/sysupgrade.bin := \
+    ls-clean | \
+    ls-append-sdhead $(1) | pad-to 16M | \
+    append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+    append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
 endef
-TARGET_DEVICES += ls1046ardb-sdboot
+TARGET_DEVICES += fsl_ls1046a-rdb-sdboot
 
-define Device/ls1088ardb
+define Device/fsl_ls1088a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1088A-RDB
   DEVICE_VARIANT := Default
   DEVICE_PACKAGES += \
-    layerscape-mc-ls1088ardb \
-    layerscape-dpl-ls1088ardb \
-    tfa-ls1088ardb \
-    restool
-  DEVICE_DTS := freescale/fsl-ls1088a-rdb
-  UBINIZE_OPTS := -E 5
-  BLOCKSIZE := 256KiB
-  PAGESIZE := 1
+    layerscape-mc \
+    layerscape-dpl \
+    tfa-ls1088a-rdb \
+    restool \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -205,47 +229,54 @@ define Device/ls1088ardb
     ls-append $(1)-dpc.dtb | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
-    append-ubi | check-size 67108865
+    append-rootfs | pad-rootfs | check-size
 endef
-TARGET_DEVICES += ls1088ardb
+TARGET_DEVICES += fsl_ls1088a-rdb
 
-define Device/ls1088ardb-sdboot
+define Device/fsl_ls1088a-rdb-sdboot
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1088A-RDB
   DEVICE_VARIANT := SD Card Boot
   DEVICE_PACKAGES += \
-    layerscape-mc-ls1088ardb \
-    layerscape-dpl-ls1088ardb \
-    tfa-ls1088ardb-sdboot \
-    restool
+    layerscape-mc \
+    layerscape-dpl \
+    tfa-ls1088a-rdb-sdboot \
+    restool \
+    kmod-ahci-qoriq \
+    kmod-hwmon-ina2xx \
+    kmod-hwmon-lm90
   DEVICE_DTS := freescale/fsl-ls1088a-rdb
   FILESYSTEMS := ext4
-  IMAGES := sdcard.img
+  IMAGES := sdcard.img sysupgrade.bin
   IMAGE/sdcard.img := \
     ls-clean | \
     ls-append-sdhead $(1) | pad-to 4K | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
     ls-append $(1)-fip.bin | pad-to 5M | \
     ls-append $(1)-uboot-env.bin | pad-to 10M | \
-    ls-append ls1088ardb-mc.itb | pad-to 13M | \
-    ls-append ls1088ardb-dpl.dtb | pad-to 14M | \
-    ls-append ls1088ardb-dpc.dtb | pad-to 15M | \
+    ls-append fsl_ls1088a-rdb-mc.itb | pad-to 13M | \
+    ls-append fsl_ls1088a-rdb-dpl.dtb | pad-to 14M | \
+    ls-append fsl_ls1088a-rdb-dpc.dtb | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
     append-rootfs | check-size $(LS_SD_IMAGE_SIZE)
+  IMAGE/sysupgrade.bin := \
+    ls-clean | \
+    ls-append-sdhead $(1) | pad-to 16M | \
+    append-kernel | pad-to $(LS_SD_ROOTFSPART_OFFSET)M | \
+    append-rootfs | check-size $(LS_SD_IMAGE_SIZE) | append-metadata
 endef
-TARGET_DEVICES += ls1088ardb-sdboot
+TARGET_DEVICES += fsl_ls1088a-rdb-sdboot
 
-define Device/ls2088ardb
+define Device/fsl_ls2088a-rdb
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS2088ARDB
   DEVICE_PACKAGES += \
-    layerscape-mc-ls2088ardb \
-    layerscape-dpl-ls2088ardb \
-    tfa-ls2088ardb \
-    restool
-  DEVICE_DTS := freescale/fsl-ls2088a-rdb
-  FILESYSTEMS := squashfs
+    layerscape-mc \
+    layerscape-dpl \
+    tfa-ls2088a-rdb \
+    restool \
+    kmod-ahci-qoriq
   IMAGE/firmware.bin := \
     ls-clean | \
     ls-append $(1)-bl2.pbl | pad-to 1M | \
@@ -256,11 +287,11 @@ define Device/ls2088ardb
     ls-append $(1)-dpc.dtb | pad-to 15M | \
     ls-append-dtb $$(DEVICE_DTS) | pad-to 16M | \
     append-kernel | pad-to 32M | \
-    append-rootfs | pad-rootfs | check-size 67108865
+    append-rootfs | pad-rootfs | check-size
 endef
-TARGET_DEVICES += ls2088ardb
+TARGET_DEVICES += fsl_ls2088a-rdb
 
-define Device/traverse-ls1043
+define Device/traverse_ls1043
   DEVICE_VENDOR := Traverse
   DEVICE_MODEL := LS1043 Boards
   KERNEL_NAME := Image
@@ -268,10 +299,11 @@ define Device/traverse-ls1043
   KERNEL_INSTALL := 1
   FDT_LOADADDR = 0x90000000
   FILESYSTEMS := ubifs
+  MKUBIFS_OPTS := -m 1 -e 262016 -c 128
   DEVICE_PACKAGES += \
-    layerscape-fman-ls1043ardb \
+    layerscape-fman \
     uboot-envtools \
-    kmod-i2c-core kmod-i2c-mux-pca954x \
+    kmod-i2c-mux-pca954x \
     kmod-hwmon-core \
     kmod-gpio-pca953x kmod-input-gpio-keys-polled \
     kmod-rtc-isl1208
@@ -287,5 +319,6 @@ define Device/traverse-ls1043
   IMAGE/root = append-rootfs
   IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
   MKUBIFS_OPTS := -m 2048 -e 124KiB -c 4096
+  SUPPORTED_DEVICES := traverse,ls1043s traverse,ls1043v
 endef
-TARGET_DEVICES += traverse-ls1043
+TARGET_DEVICES += traverse_ls1043