layerscape: move rework-sdcard-images out of fsl-sdboot
[openwrt/openwrt.git] / target / linux / layerscape / image / armv8_64b.mk
index a3f442829951dc2a1ea85d7a592bc4a53bc60e4f..958faa270e85daf28f05816bae4ed8014d340575 100644 (file)
@@ -1,9 +1,6 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright 2018-2020 NXP
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
 define Device/Default
   PROFILES := Default
@@ -23,7 +20,6 @@ define Device/Default
 endef
 
 define Device/fsl-sdboot
-  $(Device/rework-sdcard-images)
   KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
   IMAGES := sdcard.img.gz sysupgrade.bin
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -79,6 +75,7 @@ endef
 TARGET_DEVICES += fsl_ls1012a-rdb
 
 define Device/fsl_ls1012a-frwy-sdboot
+  $(Device/rework-sdcard-images)
   $(Device/fsl-sdboot)
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := FRWY-LS1012A
@@ -129,6 +126,7 @@ endef
 TARGET_DEVICES += fsl_ls1043a-rdb
 
 define Device/fsl_ls1043a-rdb-sdboot
+  $(Device/rework-sdcard-images)
   $(Device/fsl-sdboot)
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1043A-RDB
@@ -179,6 +177,7 @@ endef
 TARGET_DEVICES += fsl_ls1046a-rdb
 
 define Device/fsl_ls1046a-rdb-sdboot
+  $(Device/rework-sdcard-images)
   $(Device/fsl-sdboot)
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1046A-RDB
@@ -231,6 +230,7 @@ endef
 TARGET_DEVICES += fsl_ls1088a-rdb
 
 define Device/fsl_ls1088a-rdb-sdboot
+  $(Device/rework-sdcard-images)
   $(Device/fsl-sdboot)
   DEVICE_VENDOR := NXP
   DEVICE_MODEL := LS1088A-RDB