kernel: 5.4: import wireguard backport
[openwrt/openwrt.git] / target / linux / layerscape / patches-5.4 / 804-crypto-0001-crypto-add-support-for-TLS-1.0-record-encryption.patch
index ad557fa823d2382b15bc18b228e6bed54606aaa6..c73baa42ea89f2be55e10f7a09f6736a88a25f74 100644 (file)
@@ -28,7 +28,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
 
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -342,6 +342,26 @@ config CRYPTO_ECHAINIV
+@@ -349,6 +349,26 @@ config CRYPTO_ECHAINIV
          a sequence number xored with a salt.  This is the default
          algorithm for CBC.
  
@@ -57,7 +57,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  config CRYPTO_CBC
 --- a/crypto/Makefile
 +++ b/crypto/Makefile
-@@ -143,6 +143,7 @@ obj-$(CONFIG_CRYPTO_CRC32) += crc32_gene
+@@ -144,6 +144,7 @@ obj-$(CONFIG_CRYPTO_CRC32) += crc32_gene
  obj-$(CONFIG_CRYPTO_CRCT10DIF) += crct10dif_common.o crct10dif_generic.o
  obj-$(CONFIG_CRYPTO_AUTHENC) += authenc.o authencesn.o
  obj-$(CONFIG_CRYPTO_LZO) += lzo.o lzo-rle.o
@@ -329,7 +329,7 @@ Signed-off-by: Horia Geantă <horia.geanta@nxp.com>
  static int alg_test_aead(const struct alg_test_desc *desc, const char *driver,
                         u32 type, u32 mask)
  {
-@@ -5012,6 +5241,15 @@ static const struct alg_test_desc alg_te
+@@ -5042,6 +5271,15 @@ static const struct alg_test_desc alg_te
                        .hash = __VECS(tgr192_tv_template)
                }
        }, {