kernel: update 3.10 to 3.10.36
[openwrt/openwrt.git] / target / linux / malta / Makefile
index 69fae6aa5b8caeacec010691f7e6b0035873a162..b29568fdfec2d04f2720759d1835c7b790da5898 100644 (file)
@@ -1,23 +1,23 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mipsel
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
-FEATURES:=ramdisk
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+SUBTARGETS:=le be le64 be64
+INITRAMFS_EXTRA_FILES:=
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.32.8
+LINUX_VERSION:=3.10.36
+
+DEVICE_TYPE:=developerboard
 
 include $(INCLUDE_DIR)/target.mk
 
-define Target/Description
-       Build firmware images for MTI Malta CoreLV boards.
-endef
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim kmod-pcnet32
 
 $(eval $(call BuildTarget))