mediatek: add support for Ubiquiti UniFi 6 LR
[openwrt/openwrt.git] / target / linux / mediatek / image / mt7622.mk
index 0851184dcbce5f4f7e68938e2f51022b95e46b77..bf706930e4672f08f4a0f1f613df8cae96a74a2d 100644 (file)
@@ -58,3 +58,12 @@ define Device/mediatek_mt7622-ubi
   DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3 kmod-ata-ahci-mtk
 endef
 TARGET_DEVICES += mediatek_mt7622-ubi
+
+define Device/ubnt_unifi-6-lr
+  DEVICE_VENDOR := Ubiquiti
+  DEVICE_MODEL := UniFi 6 LR
+  DEVICE_DTS := mt7622-ubnt-unifi-6-lr
+  DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+  DEVICE_PACKAGES := kmod-mt7915e
+endef
+TARGET_DEVICES += ubnt_unifi-6-lr