mvebu: use CONFIG_MANGLE_BOOTARGS
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index a441acf238de30cac990e604ce893cfe5858aae7..163e440539a539bccf769adba3e557215b6fd316 100644 (file)
@@ -9,14 +9,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
-FEATURES:=fpu ramdisk broken
+CPU_TYPE:=8540
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=2.6.36.2
+KERNEL_PATCHVER:=3.18
+
+KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef