mpc85xx: record board id and model name in /etc/board.json
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index c6d971d2d3fb3e72c898452c441d01b1673899a5..5f3ad6c3d4968774229e51cdaab06805347189e5 100644 (file)
@@ -10,14 +10,19 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
-FEATURES:=spe_fpu squashfs
+FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.15
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
        kmod-leds-gpio kmod-booke-wdt \