target/mpc85xx: check if 'generic' subtarget for image file cuImage.tl-wdr4900-v1
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index e43327acd82fcf5daf8cc735a4b64a46ed8da515..5f3ad6c3d4968774229e51cdaab06805347189e5 100644 (file)
@@ -16,10 +16,13 @@ SUBTARGETS=generic p1020
 
 KERNEL_PATCHVER:=3.18
 
-KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
-
 include $(INCLUDE_DIR)/target.mk
 
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
        kmod-leds-gpio kmod-booke-wdt \