mpc85xx: add support for Freescale (NXP) P2020RDB
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 161c8cb8168fb25e4c98a6f280f57f6425ef99ab..799f0f54dd0726854caca5ed8e8aa994860030f9 100644 (file)
@@ -12,23 +12,16 @@ BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS:=generic p1020
+SUBTARGETS:=generic p1020 p2020
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=4.14
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNEL_IMAGES := zImage
-ifeq ($(SUBTARGET),generic)
-KERNEL_IMAGES += cuImage.tl-wdr4900-v1
-endif
-
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic
 
 $(eval $(call BuildTarget))