mpc85xx: add support for Freescale (NXP) P2020RDB
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 1a744ebcc86b8f6554bf24271df2a8a02d1b0a75..799f0f54dd0726854caca5ed8e8aa994860030f9 100644 (file)
@@ -9,18 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk broken
+CPU_TYPE:=8540
+FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic p1020 p2020
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=4.14
 
-include $(INCLUDE_DIR)/target.mk
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-booke-wdt
+include $(INCLUDE_DIR)/target.mk
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic
 
 $(eval $(call BuildTarget))