mpc85xx: add support for Freescale (NXP) P2020RDB
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 7b375d607569ff9814a18e5c3c713d6b11994b20..799f0f54dd0726854caca5ed8e8aa994860030f9 100644 (file)
@@ -10,21 +10,18 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
-FEATURES:=spe_fpu squashfs
+FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020 p2020
 
-LINUX_VERSION:=3.10.24
+KERNEL_PATCHVER:=4.14
+
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic
 
 $(eval $(call BuildTarget))