mpc85xx: add support for Freescale (NXP) P2020RDB
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index e43327acd82fcf5daf8cc735a4b64a46ed8da515..799f0f54dd0726854caca5ed8e8aa994860030f9 100644 (file)
@@ -12,21 +12,16 @@ BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020 p2020
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.14
 
-KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic
 
 $(eval $(call BuildTarget))