mpc85xx: switch to Kernel 5.10
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 262e1b9e3c7637f4d900f909d08f4a6b555f1f9f..b89bfc3ed158003e6c62e88d367df5180447978b 100644 (file)
@@ -1,29 +1,24 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu squashfs
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+CPU_TYPE:=8540
+FEATURES:=squashfs ramdisk
+SUBTARGETS:=p1010 p1020 p2020
 
-LINUX_VERSION:=3.7.10
+KERNEL_PATCHVER:=5.10
+
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-wolfssl kmod-usb2
 
 $(eval $(call BuildTarget))