mpc85xx: switch to Kernel 5.10
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index c84c0e291150bd4716b63e6c8b2c9fb8ce69607f..b89bfc3ed158003e6c62e88d367df5180447978b 100644 (file)
@@ -1,26 +1,24 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+CPU_TYPE:=8540
+FEATURES:=squashfs ramdisk
+SUBTARGETS:=p1010 p1020 p2020
 
-LINUX_VERSION:=3.7.8
+KERNEL_PATCHVER:=5.10
 
-include $(INCLUDE_DIR)/target.mk
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-booke-wdt
+include $(INCLUDE_DIR)/target.mk
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-wolfssl kmod-usb2
 
 $(eval $(call BuildTarget))