kernel: update linux 3.7 to 3.7.9
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index ef67446f937dd70ced53d61cf8fe5a67773eea88..cde1990e988fca7b80c2f582e1d85a0d134b7ed2 100644 (file)
@@ -9,14 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
-FEATURES:=spe_fpu ramdisk broken
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+FEATURES:=spe_fpu ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.4
+LINUX_VERSION:=3.7.9
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-booke-wdt
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef