kernel: update 3.10 to 3.10.28
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index ef67446f937dd70ced53d61cf8fe5a67773eea88..d68c4dac27e5820ce3b74a43eabea21a7c1c899d 100644 (file)
@@ -9,14 +9,20 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
-FEATURES:=spe_fpu ramdisk broken
+CPU_TYPE:=8540
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=2.6.36.4
+LINUX_VERSION:=3.10.28
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef