ppc4xx: remove booke-wdt watchdog package
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index e43327acd82fcf5daf8cc735a4b64a46ed8da515..efd48d7d41cc3d93fd60dde2cf6c7bd0e2996d46 100644 (file)
@@ -14,16 +14,18 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-KERNEL_PATCHVER:=3.18
-
-KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.