mvebu: fix OpenBlocks AX3 image
[openwrt/openwrt.git] / target / linux / mvebu / image / Makefile
index 09f075bbdb28ef6e3d6f150b45cbed4e01eb5465..7900fb9ddb4f0e3a6f03034b3d60e26fcdd6fd38 100644 (file)
@@ -34,7 +34,6 @@ endef
 # MBR:            2048 sectors
 # Partition 1:   32768 sectors
 # Partition 2:   98304 sectors (configurable)
-# Partition 3: 7611392 sectors (configurable, depends on p2 size)
 
 define Build/boot-scr
        rm -f $@.bootscript
@@ -50,16 +49,11 @@ define Build/boot-img
 endef
 
 define Build/sdcard-img
-       rm -rf $@ $@.rootfsdata $@.tmp
-       mkdir -p $@.tmp
        ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
-       DATA_SIZE=$$(( 7709696 - ($(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2) )); \
-       make_ext4fs -J -l $$DATA_SIZE $@.rootfsdata $@.tmp && \
-       ./gen_mvebu_sdcard_img.sh 7744512 $@ \
+       ./gen_mvebu_sdcard_img.sh $@ \
                "$(BIN_DIR)/uboot-mvebu-clearfog/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
                c 32768 $@.boot \
-               83 $$ROOTFS_SIZE $(IMAGE_ROOTFS) \
-               83 $$DATA_SIZE $@.rootfsdata
+               83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
 endef
 
 define Device/Default
@@ -147,7 +141,7 @@ define Device/openblocks-ax3
   DEVICE_DTS := armada-xp-openblocks-ax3-4
   BLOCKSIZE := 128k
   PAGESIZE := 1
-  IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+  IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
 TARGET_DEVICES += openblocks-ax3
@@ -182,7 +176,7 @@ define Device/armada-388-clearfog
   KERNEL_INSTALL := 1
   KERNEL := dtb | kernel-bin
   DEVICE_TITLE := SolidRun ClearFog
-  DEVICE_PACKAGES := uboot-mvebu-clearfog
+  DEVICE_PACKAGES := uboot-mvebu-clearfog mkf2fs e2fsprogs
   IMAGES := bundle.tar.gz sdcard.img.gz
   IMAGE/bundle.tar.gz := clearfog-bundle
   IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip