mvebu: add sysupgrade support for clearfog
[openwrt/openwrt.git] / target / linux / mvebu / image / Makefile
index a3d95501f5f8f7cf7a33271bb6884560d97774fe..b0cc1648ef4baceb7587a6f2b1bdb10e9e294b2a 100644 (file)
@@ -12,9 +12,50 @@ include $(INCLUDE_DIR)/image.mk
 
 KERNEL_LOADADDR := 0x00008000
 
 
 KERNEL_LOADADDR := 0x00008000
 
-DEVICE_VARS += KERNEL_SIZE
+define Build/dtb
+        $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
+endef
+
+define Build/clearfog-bundle
+       rm -f $@.new
+       $(TAR) -cp --numeric-owner --owner=0 --group=0 --sort=name \
+               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
+               --file=$@.new -C $(TARGET_DIR)/ .
+       $(TAR) -rp --numeric-owner --owner=0 --group=0 --sort=name \
+               $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
+               --file=$@.new -C $(dir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL)) $(notdir $(IMAGE_KERNEL).dtb)
+       gzip -9n -c $@.new > $@
+endef
+
+# SD-Card Images:
+# these values are optimized for a 4GB labeled sdcard that actually holds 7744512 sectors of 512 byte
+# MBR:            2048 sectors
+# Partition 1:   32768 sectors
+# Partition 2:   98304 sectors (configurable)
+
+define Build/boot-scr
+       rm -f $@.bootscript
+       mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d boot.script $@.bootscript
+endef
+
+define Build/boot-img
+       rm -f $@.boot
+       mkfs.fat -C $@.boot 16384
+       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb)
+       mcopy -i $@.boot $(IMAGE_KERNEL) ::zImage
+       mcopy -i $@.boot $@.bootscript ::boot.scr
+endef
+
+define Build/sdcard-img
+       ROOTFS_SIZE=$$(( $(CONFIG_TARGET_ROOTFS_PARTSIZE) * 1024 * 2 )); \
+       ./gen_mvebu_sdcard_img.sh $@ \
+               "$(KDIR)/openwrt-mvebu-clearfog-u-boot-spl.kwb" \
+               c 32768 $@.boot \
+               83 $$ROOTFS_SIZE $(IMAGE_ROOTFS)
+endef
 
 define Device/Default
 
 define Device/Default
+  PROFILES := Default
   DEVICE_DTS := $(1)
   BOARD_NAME = $$(DEVICE_DTS)
   KERNEL_NAME := zImage
   DEVICE_DTS := $(1)
   BOARD_NAME = $$(DEVICE_DTS)
   KERNEL_NAME := zImage
@@ -23,18 +64,19 @@ endef
 
 define Device/UBI
   IMAGES := sysupgrade.bin
 
 define Device/UBI
   IMAGES := sysupgrade.bin
-  IMAGE/sysupgrade.bin := sysupgrade-nand
+  IMAGE/sysupgrade.bin := sysupgrade-tar
 endef
 
 define Device/UBI-factory
   $(Device/UBI)
 endef
 
 define Device/UBI-factory
   $(Device/UBI)
+  UBINIZE_OPTS := -E 5
   IMAGES += factory.img
   IMAGES += factory.img
-  IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
+  IMAGE/factory.img := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | pad-to $$$$(PAGESIZE)
 endef
 
 define Device/NAND-128K
   $(Device/UBI)
 endef
 
 define Device/NAND-128K
   $(Device/UBI)
-  BLOCKSIZE := 128KiB
+  BLOCKSIZE := 128k
   PAGESIZE := 2048
   SUBPAGESIZE := 512
   VID_HDR_OFFSET := 2048
   PAGESIZE := 2048
   SUBPAGESIZE := 512
   VID_HDR_OFFSET := 2048
@@ -42,13 +84,13 @@ endef
 
 define Device/NAND-256K
   $(Device/UBI)
 
 define Device/NAND-256K
   $(Device/UBI)
-  BLOCKSIZE := 256KiB
+  BLOCKSIZE := 256k
   PAGESIZE := 4096
 endef
 
 define Device/NAND-512K
   $(Device/UBI)
   PAGESIZE := 4096
 endef
 
 define Device/NAND-512K
   $(Device/UBI)
-  BLOCKSIZE := 512KiB
+  BLOCKSIZE := 512k
   PAGESIZE := 4096
 endef
 
   PAGESIZE := 4096
 endef
 
@@ -96,9 +138,9 @@ TARGET_DEVICES += linksys-wrt1900ac
 define Device/openblocks-ax3
   $(Device/UBI-factory)
   DEVICE_DTS := armada-xp-openblocks-ax3-4
 define Device/openblocks-ax3
   $(Device/UBI-factory)
   DEVICE_DTS := armada-xp-openblocks-ax3-4
-  BLOCKSIZE := 128KiB
+  BLOCKSIZE := 128k
   PAGESIZE := 1
   PAGESIZE := 1
-  IMAGE/factory.img := append-kernel $$$$(KERNEL_SIZE) | append-ubi
+  IMAGE/factory.img := append-kernel | pad-to $$(BLOCKSIZE) | append-ubi
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
 TARGET_DEVICES += openblocks-ax3
   DEVICE_TITLE := Plat'Home OpenBlocks AX3
 endef
 TARGET_DEVICES += openblocks-ax3
@@ -125,13 +167,19 @@ TARGET_DEVICES += armada-370-db armada-370-rd armada-xp-db armada-xp-gp
 define Device/armada-388-rd
   DEVICE_TITLE := Marvell Armada 388 RD (RD-88F6820-AP)
   IMAGES := firmware.bin
 define Device/armada-388-rd
   DEVICE_TITLE := Marvell Armada 388 RD (RD-88F6820-AP)
   IMAGES := firmware.bin
-  IMAGE/firmware.bin := append-kernel 256k | append-rootfs | pad-rootfs
+  IMAGE/firmware.bin := append-kernel | pad-to 256k | append-rootfs | pad-rootfs
 endef
 TARGET_DEVICES += armada-388-rd
 
 define Device/armada-388-clearfog
   KERNEL_INSTALL := 1
 endef
 TARGET_DEVICES += armada-388-rd
 
 define Device/armada-388-clearfog
   KERNEL_INSTALL := 1
+  KERNEL := dtb | kernel-bin
   DEVICE_TITLE := SolidRun ClearFog
   DEVICE_TITLE := SolidRun ClearFog
+  DEVICE_PACKAGES := mkf2fs e2fsprogs swconfig kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+  IMAGES := bundle.tar.gz sdcard.img.gz
+  IMAGE/bundle.tar.gz := clearfog-bundle
+  IMAGE/sdcard.img.gz := boot-scr | boot-img | sdcard-img | gzip
+  IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
 endef
 TARGET_DEVICES += armada-388-clearfog
 
 endef
 TARGET_DEVICES += armada-388-clearfog