mvebu: add support for WRT32X (venom)
[openwrt/openwrt.git] / target / linux / mvebu / image / cortex-a9.mk
index d9defe880de6ddf0756b44688f8b4ad75db6b11e..6bc6269da6a0b11c4c136d3143e06312346f0097 100644 (file)
@@ -51,6 +51,16 @@ define Device/linksys-wrt1900acs
 endef
 TARGET_DEVICES += linksys-wrt1900acs
 
+define Device/linksys-wrt32x
+$(call Device/linksys,WRT32X (Venom))
+  DEVICE_DTS := armada-385-linksys-venom
+  DEVICE_PACKAGES += kmod-btmrvl kmod-mwifiex-sdio mwlwifi-firmware-88w8964
+  $(Device/armada-385-linksys)
+  KERNEL_SIZE := 3072k
+  KERNEL := kernel-bin | append-dtb
+endef
+TARGET_DEVICES += linksys-wrt32x
+
 define Device/linksys-wrt1900ac
   $(call Device/linksys,WRT1900AC (Mamba))
   DEVICE_DTS := armada-xp-linksys-mamba