mxs: unconditionally install kernel images/dtb files into rootfs (needed by boards)
[openwrt/openwrt.git] / target / linux / mxs / image / Makefile
index 94fed8215c3ea9eb8cf01c909372c0154d58d2e7..3898c6e1f3b1e9863a58d03aa85205f643169b1e 100644 (file)
@@ -24,24 +24,11 @@ define Image/BuildKernel
 endef
 
 define Image/InstallKernel
-
-  ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_ZIMAGE),)
-       mkdir -p $(TARGET_DIR)/boot
-       cp $(KDIR)/zImage $(TARGET_DIR)/boot/
-  endif
-
-  ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
        mkdir -p $(TARGET_DIR)/boot
-       cp $(KDIR)/uImage $(TARGET_DIR)/boot/
-  endif
-  
-  ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
-       mkdir -p $(TARGET_DIR)/boot
-       $(foreach board,$(BOARDS),
-               $(CP) $(DTS_DIR)/$(board).dtb $(TARGET_DIR)/boot/
-       )
-  endif
-
+       cp \
+               $(KDIR)/zImage $(KDIR)/uImage \
+               $(foreach board,$(BOARDS),$(DTS_DIR)/$(board).dtb) \
+               $(TARGET_DIR)/boot/
 endef
 
 define Image/Build/SDCard-vfat-ext4