mxs: adopt SD card generation to fixed U-Boot path
[openwrt/openwrt.git] / target / linux / mxs / image / Makefile
index 55e88c25f3f344d5982f84a44e599f354f43526b..7e6a1a000cd30fbd9b405f3c54ea0236979cc55b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,6 +9,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 include $(INCLUDE_DIR)/host.mk
 
+BOARDS:= \
+       imx23-olinuxino \
+       imx28-duckbill
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_MXS_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
@@ -22,9 +25,14 @@ endef
 
 define Image/InstallKernel
 
-  ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+  ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_ZIMAGE),)
        mkdir -p $(TARGET_DIR)/boot
-       $(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(TARGET_DIR)/boot/
+       cp $(KDIR)/zImage $(TARGET_DIR)/boot/
+  endif
+
+  ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+       mkdir -p $(TARGET_DIR)/boot
+       cp $(KDIR)/uImage $(TARGET_DIR)/boot/
   endif
   
   ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
@@ -49,7 +57,7 @@ define Image/Build/SDCard
                $(KDIR)/root.$(1) \
                $(CONFIG_MXS_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
-               $(BIN_DIR)/uboot-mxs-$(3).sb
+               $(BIN_DIR)/uboot-mxs-$(3)/uboot-mxs-$(3).sb
 endef
 
 define Image/Build/Profile/olinuxino-maxi
@@ -67,6 +75,7 @@ endef
 define Image/Build
        $(call Image/Build/$(1),$(1))
        $(call Image/Build/Profile/$(PROFILE),$(1))
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
 endef
 
 $(eval $(call BuildImage))