kernel: update 3.10 to 3.10.18
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 3cf814866cc85a4512bca55342c5eab48a90d4c8..35f518655b9e60b087a7b3a5edefe2c9aa42921c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+FEATURES:=squashfs jffs2 pci usb
+CPU_TYPE:=octeon
+CPU_CFLAGS_octeon:=-march=octeon
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=2.6.30-rc7
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.