kernel: update 3.10 to 3.10.18
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 4d79a1aa792e6d61214275bb8193345c8ead18f8..35f518655b9e60b087a7b3a5edefe2c9aa42921c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,14 @@ ARCH:=mips
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
 FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
+CPU_TYPE:=octeon
+CPU_CFLAGS_octeon:=-march=octeon
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=2.6.37.4
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.