kernel: update 3.10 to 3.10.18
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 68d1eafd878fe8b9bd06d7f4703960aa22fc16b2..35f518655b9e60b087a7b3a5edefe2c9aa42921c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb broken
-CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
-MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+FEATURES:=squashfs jffs2 pci usb
+CPU_TYPE:=octeon
+CPU_CFLAGS_octeon:=-march=octeon
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=2.6.37.6
+LINUX_VERSION:=3.10.18
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.