ath79: add support for TP-Link TL-WR841N/ND v12
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 3cf814866cc85a4512bca55342c5eab48a90d4c8..6c0623cb9bfac4d1169c7fb8cbdae6e47ae40ba6 100644 (file)
@@ -1,25 +1,26 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+FEATURES:=squashfs ramdisk pci usb
+CPU_TYPE:=octeonplus
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.30-rc7
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += hostapd-mini
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))