ath79: fix loader-okli, lzma-loader
[openwrt/openwrt.git] / target / linux / octeon / Makefile
index 8e9ca601672a7a65489303d08bb67414036d5373..bbf1296c21e9134f1582f685ccdad5014c9f08c0 100644 (file)
@@ -6,21 +6,21 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
+FEATURES:=squashfs ramdisk pci usb
 CPU_TYPE:=octeon
-CPU_CFLAGS_octeon:=-march=octeon
-MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-LINUX_VERSION:=3.10.36
-
-include $(INCLUDE_DIR)/target.mk
+MAINTAINER:=John Crispin <john@phrozen.org>
 
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))