octeon: increase block2mtd rootfs probe timeout on ER
[openwrt/openwrt.git] / target / linux / octeon / image / Makefile
index 3d1bdf7b17ed6a34e2898849a406707a1517d2b8..ab91d066c620446e3d18868e17786f2b8a029893 100644 (file)
@@ -9,12 +9,13 @@ include $(INCLUDE_DIR)/image.mk
 
 define Device/Default
   PROFILES = Default $$(DEVICE_NAME)
-  BOARD_NAME := $(BOARD)
   KERNEL_NAME := vmlinux.elf
   KERNEL_INITRAMFS_NAME := vmlinux-initramfs.elf
   KERNEL := kernel-bin | strip-kernel | patch-cmdline
   IMAGES := sysupgrade.tar
-  IMAGE/sysupgrade.tar := sysupgrade-nand
+  IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@
+  IMAGE/sysupgrade.tar := sysupgrade-tar
+  FILESYSTEMS := squashfs
 endef
 
 define Build/strip-kernel
@@ -28,7 +29,7 @@ define Device/generic
 endef
 TARGET_DEVICES += generic
 
-ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro block2mtd.block2mtd=/dev/mmcblk0p2,65536,rootfs,5 root=/dev/mtdblock3 rootfstype=squashfs rootwait
+ER_CMDLINE:=-mtdparts=phys_mapped_flash:640k(boot0)ro,640k(boot1)ro,64k(eeprom)ro block2mtd.block2mtd=/dev/mmcblk0p2,65536,rootfs,15 root=/dev/mtdblock3 rootfstype=squashfs rootwait
 define Device/er
   CMDLINE := $(ER_CMDLINE) 
   DEVICE_TITLE := Ubiquiti EdgeRouter