omap24xx: Set platform specific optimization flags
[openwrt/openwrt.git] / target / linux / omap24xx / Makefile
index aeaa682ff56b2ed8d4ff43df5be6c05c2937b18e..48c43857f4449ff48498084de7cb2ae4932d92ec 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=omap24xx
 BOARDNAME:=TI OMAP-24xx
-FEATURES:=squashfs jffs2
+MAINTAINER:=Michael Buesch <m@bues.ch>
+FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
 
-LINUX_VERSION:=2.6.35
+LINUX_VERSION:=3.1.1
 
 define Target/Description
        TI OMAP-24xx
 endef
 
+CFLAGS:=-Os -pipe -march=armv6 -mtune=arm1136j-s -fno-caller-saves
+
 include $(INCLUDE_DIR)/target.mk
 
 $(eval $(call BuildTarget))