layerscape: add u-boot environment support for OpenWrt boot
[openwrt/openwrt.git] / target / linux / orion / Makefile
index 1ea2545c8cb1d8db4a273039d8fa8101ed4a8b70..07583e485f23ebd7adf25496502d682e854730b2 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,20 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
-FEATURES:=squashfs
+FEATURES:=broken rtc
+SUBTARGETS:=generic harddisk
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.26-rc9
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
-
-DEFAULT_PACKAGES += kmod-madwifi
+KERNELNAME:=zImage
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
+DEFAULT_PACKAGES += kmod-ath9k wpad-mini kmod-rtc-isl1208 uboot-envtools
 
 $(eval $(call BuildTarget))