layerscape: add u-boot environment support for OpenWrt boot
[openwrt/openwrt.git] / target / linux / orion / Makefile
index 7d2a7c11903386c39f8e8899d0d73b6fd2c252cd..07583e485f23ebd7adf25496502d682e854730b2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
-FEATURES:=squashfs
-SUBTARGETS=generic harddisk
-CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
+FEATURES:=broken rtc
+SUBTARGETS:=generic harddisk
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.12
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-ath9k wpad-mini
+DEFAULT_PACKAGES += kmod-ath9k wpad-mini kmod-rtc-isl1208 uboot-envtools
 
 $(eval $(call BuildTarget))