layerscape: add u-boot environment support for OpenWrt boot
[openwrt/openwrt.git] / target / linux / orion / Makefile
index fa06466e89f603fd89f3c40adcc97f71f6a5031b..07583e485f23ebd7adf25496502d682e854730b2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
+FEATURES:=broken rtc
 SUBTARGETS:=generic harddisk
-CFLAGS=-Os -pipe -march=armv5te -mtune=xscale
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage uImage"
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini kmod-i2c-core kmod-i2c-mv64xxx kmod-rtc-isl1208
+DEFAULT_PACKAGES += kmod-ath9k wpad-mini kmod-rtc-isl1208 uboot-envtools
 
 $(eval $(call BuildTarget))