orion: upgrade to 3.18 (compile tested only)
[openwrt/openwrt.git] / target / linux / orion / Makefile
index aeb47a4f113f2f12005ff3a90548951e56f254f1..58e74b8e4a77c4bdd7b0f558ada40ffb1f24d57e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
+FEATURES:=broken
 SUBTARGETS:=generic harddisk
-CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.37.3
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini kmod-i2c-core kmod-i2c-mv64xxx kmod-rtc-isl1208
 
 $(eval $(call BuildTarget))