kernel: update spi-nor in 4.9 to spi-nor tree version (next branch)
[openwrt/openwrt.git] / target / linux / ppc40x / Makefile
index adc01938b7c4c2ec1e54c59c32a472cef2e3b3d8..3529bb3db501e4eed0db5a4b4a40647324e389e9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
+FEATURES:=squashfs broken
+CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.10
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
+
 $(eval $(call BuildTarget))