ppc40x: don't force usb feature
[openwrt/openwrt.git] / target / linux / ppc40x / Makefile
index 4c4641aa4f00fd211eb3d1c112abf415aacd1d2b..c3181ab61780989afc77c17ec0402e50a26dd729 100644 (file)
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs jffs2 usb
+FEATURES:=squashfs
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 
-LINUX_VERSION:=2.6.28.10
+LINUX_VERSION:=2.6.30.8
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Kilauea evaluation board
+       Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
 $(eval $(call BuildTarget))