mcs814x: Remove unmaintained target
[openwrt/openwrt.git] / target / linux / ppc40x / Makefile
index e350e6a18d5dcdd163e0d60e727c4410c581186c..ebe09988a8e1f90d26c4a7bae0ac189378d193fd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
+FEATURES:=squashfs small_flash broken
+CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.24
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
+
 $(eval $(call BuildTarget))