kernel: update kernel 4.4 to version 4.4.3
[openwrt/openwrt.git] / target / linux / ppc44x / Makefile
index 9c8e7eb683231a6de66777e8ccf8be6ece428dac..17a3f5893ae145467206ea636ffff46b6de761ea 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,10 +10,10 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
+CPU_TYPE:=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.30.4
-LINUX_KARCH:=powerpc
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -21,4 +21,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+KERNELNAME:=uImage cuImage.taishan
+
 $(eval $(call BuildTarget))