kernel: update kernel 4.4 to version 4.4.3
[openwrt/openwrt.git] / target / linux / ppc44x / Makefile
index fceccdf093cf04230faf440977a8334697119229..17a3f5893ae145467206ea636ffff46b6de761ea 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
-FEATURES:=squashfs broken
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+FEATURES:=squashfs
+CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.10
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
-
 define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+KERNELNAME:=uImage cuImage.taishan
+
 $(eval $(call BuildTarget))