remove redundant LINUX_KARCH variables
[openwrt/openwrt.git] / target / linux / ppc44x / Makefile
index ed43ccaec7b5d44edcb819d80297f464ddf492c9..5b536adafb017d8566e2df6449065a111e41e8d6 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=ppc44x
-BOARDNAME:=AMCC Taishan
-FEATURES:=jffs2
+BOARDNAME:=AMCC/IBM PPC44x
+FEATURES:=squashfs
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.23.14
-LINUX_KARCH:=ppc
+LINUX_VERSION:=2.6.30.10
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))