kernel: update to kernel version 2.6.32.32
[openwrt/openwrt.git] / target / linux / pxa / Makefile
index b5985ea74d1dad1d782be7262bc6bd64b7a749ef..747e4fdba073a1d7a795d6bc6cbd778cdca7b28a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=pxa
-BOARDNAME:=PXA
-FEATURES:=jffs2 broken
+BOARDNAME:=Marvell/Intel PXA2xx
+FEATURES:=squashfs
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.32.32
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Stub for boards based on intel PXA
+       Build images for PXA2xx systems, eg. Gumstix.
 endef
 
+KERNELNAME:="uImage"
+
 $(eval $(call BuildTarget))