mvebu: set fan_ctrl.sh only on mamba
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index c3fb0c323b5de3875babe38490efb283131e47dd..25859024c1021a33ffbe40e14b1a74f33376584a 100644 (file)
@@ -8,21 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
+FEATURES:=squashfs gpio
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.2.5
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini maccalc
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+
 $(eval $(call BuildTarget))