ramips: fix subtarget kernel version assignment (only mt7621 is ready for now)
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index f09f1097ec659a0a9ca9fb68048b7383a200f246..378e2f5b4a80c73a307f017e220cc8a688ec47f9 100644 (file)
@@ -9,16 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt305x rt3883 mt7620a rt288x
-FEATURES:=squashfs gpio
+SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
+FEATURES:=squashfs gpio mips16
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.18
+KERNEL_PATCHVER:=4.3
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini swconfig
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.