ramips: add support for Planex MZK-WDPR.
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index 9598d8674f5c9bb841e92624f90e86d4cc390d10..55a8fd62ed06c4f00c24e5cfde04b37b889bca08 100644 (file)
@@ -8,20 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT305x
-SUBTARGETS:=rt288x rt305x
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
+FEATURES:=squashfs gpio mips16
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=2.6.39.2
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev kmod-gpio-buttons \
-       kmod-button-hotplug kmod-wpad-mini
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
 
 define Target/Description
-       Build firmware images for Ralink RT288x/RT305x based boards.
+       Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
 $(eval $(call BuildTarget))