ramips: gsw_mt7621: disable PORT 5 MAC RX/TX flow control by default
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index 60302871e955e25caacf5138cab1c069d2a372e5..887b5909e4615afe7a43ef0f46dfc1496ed78add 100644 (file)
@@ -8,21 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=mt7620 mt7621 mt76x8 rt288x rt305x rt3883
 FEATURES:=squashfs gpio
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.8.3
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini swconfig
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig
+
 $(eval $(call BuildTarget))