ramips: gsw_mt7621: disable PORT 5 MAC RX/TX flow control by default
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index a2f6156575f5b14a7c68ef9109b6ed2a4071d6c4..887b5909e4615afe7a43ef0f46dfc1496ed78add 100644 (file)
@@ -8,19 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt305x mt7620a mt7620n mt7621 rt3883 rt288x
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=mt7620 mt7621 mt76x8 rt288x rt305x rt3883
 FEATURES:=squashfs gpio
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.10.24
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-gpio-button-hotplug \
-       kmod-rt2800-pci kmod-rt2800-soc wpad-mini swconfig
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig
+
 $(eval $(call BuildTarget))