ramips: add button support and make LEDs known to userspace for DIR-860L B1
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index bb3f4f13929ac7752bec0a995fb4ea6f7886a0e2..b4ccaf64e1d27355907ac697e4b77e6a68ba922a 100644 (file)
@@ -8,18 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=ramips
-BOARDNAME:=Ralink RT288x/RT3xxx
-SUBTARGETS:=rt288x rt305x rt3883 mt7620a
-CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
-FEATURES:=squashfs gpio
+BOARDNAME:=MediaTek Ralink MIPS
+SUBTARGETS:=rt305x mt7620 mt7621 mt7628 mt7688 rt3883 rt288x
+FEATURES:=squashfs gpio mips16
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.10.2
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=\
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini swconfig
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.