add initial support for the WZR-AGL300NH - patch by Joonas Lahtinen <joonas.lahtinen...
[openwrt/openwrt.git] / target / linux / ramips / files / arch / mips / ralink / rt288x / Makefile
index 4c22a6dc8a6fc37dd5b63a61af4a3d8aa4b54c5d..dda3e063fa82d09a90363d10ed0316e186ef0a34 100644 (file)
@@ -1,6 +1,7 @@
 #
 # Makefile for the Ralink RT288x SoC specific parts of the kernel
 #
+# Copyright (C) 2010 Joonas Lahtinen <joonas.lahtinen@gmail.com>
 # Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
 # Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
 #
@@ -8,8 +9,10 @@
 # under the terms of the GNU General Public License version 2 as published
 # by the Free Software Foundation.
 
-obj-y  := prom.o irq.o setup.o rt288x.o platform.o
+obj-y  := irq.o setup.o rt288x.o devices.o
 
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
-obj-$(CONFIG_RT288X_MACH_GENERIC)      += mach-generic.o
+obj-$(CONFIG_RT288X_MACH_RT_N15)       += mach-rt-n15.o
+
+obj-$(CONFIG_RT288X_MACH_WZR_AGL300NH) += mach-wzr-agl300nh.o