ramips: Add support for TEW-714TRU
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index 52dde6780ec07c37a319290ab0157717cb2398da..44508b630cfea0ed6de03df44efceae53c676f85 100644 (file)
@@ -22,7 +22,7 @@ define Image/Build/Initramfs
        $(call Image/Build/Profile/$(PROFILE),initramfs)
 endef
 
-DEVICE_VARS += DTS IMAGE_SIZE
+DEVICE_VARS += DTS IMAGE_SIZE KERNEL_SIZE
 
 loadaddr-y := 0x80000000
 loadaddr-$(CONFIG_TARGET_ramips_rt288x) := 0x88000000
@@ -49,8 +49,8 @@ define Build/trx
        $(STAGING_DIR_HOST)/bin/trx \
                -o $@ \
                -m $(IMAGE_SIZE) \
-               -f $(word 1,$^) \
-               -a 4 -f $(word 2,$^)
+               -f $(IMAGE_KERNEL) \
+               -a 4 -f $(IMAGE_ROOTFS)
 endef
 
 define Build/relocate-kernel
@@ -246,6 +246,7 @@ endif
 
 ifeq ($(SUBTARGET),rt305x)
 include rt305x.mk
+include rt305x-legacy.mk
 endif
 
 ifeq ($(SUBTARGET),rt3883)