ramips: generate sysupgrade image for the ALL0256N
[openwrt/openwrt.git] / target / linux / ramips / image / Makefile
index 24f59663ccfa1c809cc8597da42dd724e327474e..c6b214ff36b2b1b183c5ccf55ef6bec22ee1fb2e 100644 (file)
@@ -89,6 +89,10 @@ define BuildFirmware/Buffalo
        fi; fi
 endef
 
+define BuildFirmware/Buffalo2
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),$($(4)),$(5),$(6))
+endef
+
 define BuildFirmware/NW718
        $(call PatchKernelLzma,$(2),$(3) $($(4)))
        mkimage -A mips -O linux -T kernel -C lzma $(call kernel_entry) \
@@ -119,8 +123,10 @@ define Image/Build/Template/GENERIC_4M
 endef
 
 mtdlayout_8M=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
+kernel_size_8M=851968
+rootfs_size_8M=7208960
 define Image/Build/Template/GENERIC_8M
-       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_8M,851968,7208960)
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_8M,$(kernel_size_8M),$(rootfs_size_8M))
 endef
 
 mtdlayout_dir300b1=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(devdata)ro,64k(devconf)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
@@ -139,6 +145,12 @@ define Image/Build/Template/NW718
        $(call BuildFirmware/NW718,$(1),$(2),board=$(3),mtdlayout_nw718,851968,2949120)
 endef
 
+console_OMNIEMB=ttyS1,57600
+mtdlayout_ONMIEMB=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1024k(kernel),6848k(rootfs),7872k@0x50000(firmware)
+define Image/Build/Template/OMNIEMB
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) console=$(console_OMNIEMB),mtdlayout_OMNIEMB,1048576,7012352)
+endef
+
 define Image/Build/Profile/DIR300B1
        $(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
        $(call Image/Build/Template/DIR300B1,$(1),dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
@@ -156,6 +168,10 @@ define Image/Build/Profile/RTG32B1
        $(call Image/Build/Template/RTG32B1,$(1),rt-g32-b1,RT-G32-B1)
 endef
 
+define Image/Build/Profile/ESR9753
+       $(call Image/Build/Template/GENERIC_4M,$(1),esr-9753,ESR-9753)
+endef
+
 define Image/Build/Profile/FONERA20N
        $(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
        $(call BuildFirmware/Edimax,$(1),fonera20n,RSDK,NL1T,0x50000,0xc0000)
@@ -165,14 +181,26 @@ define Image/Build/Profile/BC2
        $(call Image/Build/Template/GENERIC_8M,$(1),bc2,BC2)
 endef
 
+define Image/Build/Profile/ALL0256N
+       $(call Image/Build/Template/GENERIC_4M,$(1),all0256n,ALL0256N)
+endef
+
 define Image/Build/Profile/NBG419N
        $(call Image/Build/Template/GENERIC_4M,$(1),nbg-419n,NBG-419N)
 endef
 
+define Image/Build/Profile/WL351
+       $(call Image/Build/Template/GENERIC_4M,$(1),wl-351,WL-351)
+endef
+
 define Image/Build/Profile/NW718
        $(call Image/Build/Template/NW718,$(1),nw718,NW718)
 endef
 
+define Image/Build/Profile/OMNIEMB
+       $(call Image/Build/Template/OMNIEMB,$(1),omni-emb,OMNI-EMB)
+endef
+
 define Image/Build/Profile/PWH2004
        $(call Image/Build/Template/GENERIC_8M,$(1),pwh2004,PWH2004)
 endef
@@ -206,6 +234,10 @@ define Image/Build/Profile/WCR150GN
        $(call Image/Build/Template/GENERIC_4M,$(1),wcr150gn,WCR150GN)
 endef
 
+w502u_cmdline=board=W502U console=ttyS1,115200
+define Image/Build/Profile/W502U
+       $(call BuildFirmware/Generic,$(1),w502u,$(w502u_cmdline),mtdlayout_8M,$(kernel_size_8M),$(rootfs_size_8M))
+endef
 
 mtdlayout_argus_atp52b=mtdparts=physmap-flash.0:192k(bootloader)ro,64k(config),64k(factory),1152k(kernel),6656k(rootfs),7808k@0x50000(firmware)
 mtd_argus_atp52b_kernel_part_size=1179648
@@ -229,6 +261,10 @@ define Image/Build/Profile/F5D8235V2
        $(call Image/Build/Template/F5D8235V2,$(1),f5d8235v2,F5D8235_V2)
 endef
 
+define Image/Build/Template/F5D8235V1
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3),mtdlayout_f5d8235,$(mtd_f5d8235_kernel_part_size),$(mtd_f5d8235_rootfs_part_size))
+endef
+
 
 mtdlayout_wr5123gn=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
 mtdlayout_wr5123gn8m=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),7040k(rootfs),7872k@0x50000(firmware)
@@ -237,35 +273,49 @@ define Image/Build/Profile/WR5123GN
        $(call BuildFirmware/Generic,$(1),wr512-3gn-8M,board="WR512-3GN",mtdlayout_wr5123gn8m,851968,7208960)
 endef
 
-
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/BC2,$(1))
+       $(call Image/Build/Profile/ALL0256N,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
+       $(call Image/Build/Profile/ESR9753,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/V22RW2X2,$(1))
        $(call Image/Build/Profile/NBG419N,$(1))
        $(call Image/Build/Profile/NW718,$(1))
+       $(call Image/Build/Profile/OMNIEMB,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/F5D8235V2,$(1))
        $(call Image/Build/Profile/HW5503G,$(1))
        $(call Image/Build/Profile/MOFI35003GN,$(1))
+       $(call Image/Build/Profile/W502U,$(1))
        $(call Image/Build/Profile/WR5123GN,$(1))
+       $(call Image/Build/Profile/WL351,$(1))
 endef
 endif
 
+define Image/Build/Profile/F5D8235V1
+       $(call Image/Build/Template/F5D8235V1,$(1),f5d8235v1,F5D8235_V1)
+endef
 
 define Image/Build/Profile/RTN15
        $(call Image/Build/Template/GENERIC_4M,$(1),rt-n15,RT-N15)
 endef
 
+mtdlayout_wlitx4ag300n=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2880k(rootfs),64k(user)ro,3712k@0x50000(firmware)
+define Image/Build/Profile/WLITX4AG300N
+       $(call BuildFirmware/Buffalo2,$(1),wli-tx4-ag300n,WLI-TX4-AG300N,mtdlayout_wlitx4ag300n,851968,2949120)
+endef
+
 ifeq ($(CONFIG_RALINK_RT288X),y)
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/F5D8235V1,$(1))
        $(call Image/Build/Profile/RTN15,$(1))
+       $(call Image/Build/Profile/WLITX4AG300N,$(1))
 endef
 endif